inReach service activation and plan change delays
Incident Report for Garmin inReach
Resolved
All queued service plan changes have completed and the system is operating normally at this time.
Posted Sep 04, 2020 - 05:39 EDT
Monitoring
Delayed inReach service changes are processing more quickly and we are monitoring as they are completed.
Posted Sep 03, 2020 - 23:27 EDT
Update
We are continuing to investigate this issue.
Posted Sep 03, 2020 - 19:29 EDT
Investigating
New inReach service activation and plan changes are currently processing slowly. We recommend waiting until the issue is resolved before making any service changes.
Posted Sep 03, 2020 - 17:46 EDT
This incident affected: Iridium Activation and Subscription Billing.