Some Explore users are unable to login
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Jan 14, 2022 - 14:15 EST
Identified
Garmin users with MFA enabled are unable to login because one-time codes are currently blocked for North American customers.
Posted Jan 14, 2022 - 10:39 EST
This incident affected: Garmin Sign In.