New inReach service activation and plan change delay/outage
Incident Report for Garmin inReach
Resolved
The issue appears to be resolved and we are watching to ensure delayed activations and plan changes are going through.
Posted about 1 year ago. Jul 17, 2018 - 13:54 EDT
Investigating
New inReach service activation and plan changes are currently experiencing delays. When the issue is resolved, all pending changes will happen. Updates will be provided.
Posted about 1 year ago. Jul 17, 2018 - 13:38 EDT
This incident affected: inReach Service Activation and Billing.