Service delays possible
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Jan 25, 2023 - 08:07 EST
Identified
Since 07:05 UTC, customers can experience intermittent delays and slowness with affected services due to a third-party provider's outage.

SOS is not impacted.
Posted Jan 25, 2023 - 05:11 EST
This incident affected: Iridium Activation and Subscription Billing, LTE Activation and Subscription Billing, Developer APIs, and Garmin Explore Mobile App.