New inReach service activation outage for European customers
Incident Report for Garmin inReach
Resolved
inReach service activation is working normally.
Posted 8 months ago. Jul 11, 2018 - 22:08 EDT
Investigating
We are investigating an issue with inReach service activation for European customers. Updates will be provided.
Posted 8 months ago. Jul 11, 2018 - 20:50 EDT
This incident affected: inReach Service Activation and Billing.