Explore site sign in and inReach Sync app sign in outage
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted about 1 year ago. Jul 30, 2018 - 15:10 EDT
Investigating
Signing in to the Explore site and the inReach Sync app is intermittently unavailable. Updates will be provided. inReach communication is not affected.
Posted about 1 year ago. Jul 30, 2018 - 14:46 EDT
This incident affected: Garmin Explore Website and MapShare.