Earthmate and inReach Sync app sign in issues
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Dec 02, 2019 - 15:28 EST
Investigating
We are currently investigating an issue for Earthmate mobile app and inReach Sync desktop app customers being unable to sign in and sync. The Explore website and Explore mobile app are not affected.
Posted Dec 02, 2019 - 14:04 EST
This incident affected: Garmin Sign In.