Intermittent Explore Site Sign In and New inReach Service Activation Issues
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted 5 months ago. Oct 09, 2018 - 12:14 EDT
Investigating
Some customers may experience issues with signing into the Explore site or with activating new inReach service. Updates will be provided.
Posted 5 months ago. Oct 09, 2018 - 11:34 EDT
This incident affected: Garmin Explore Website and MapShare and inReach Service Activation and Billing.