Some customers cannot activate inReach service
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 30, 2019 - 13:48 EDT
Investigating
Some customers are experiencing web site errors when attempting to activate inReach service. We are investigating and will provide updates.
Posted 3 months ago. Mar 29, 2019 - 14:23 EDT
This incident affected: inReach Service Activation and Billing.