Some users may be unable to access or edit User or Contacts
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Apr 14, 2021 - 16:15 EDT
Update
We are continuing to work on this issue. We do not have a new estimated time to resolve this.
Posted Apr 13, 2021 - 16:41 EDT
Investigating
Users on the Explore website may experience interment errors when trying to access and edit Contacts. We are currently investigating this issue and may have a resolution or an additional update by 3:30PM EST.
Posted Apr 13, 2021 - 11:35 EDT
This incident affected: Garmin Explore Website and MapShare.