inReach Service Activation Unavailable
Incident Report for Garmin inReach
Resolved
inReach service activations are working normally. Any activations that were delayed are now being processed.
Posted Apr 16, 2018 - 09:46 EDT
Investigating
Activating new service plans for inReach devices is currently unavailable. Updates will be provided.
Posted Apr 16, 2018 - 09:14 EDT
This incident affected: Iridium Activation and Subscription Billing.