Subscription activation, plan switch and deactivation delays
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Jan 25, 2023 - 14:40 EST
Investigating
Subscription activation, plan switch and deactivation delay. Since about 11:41 AM Eastern US (4:41 PM UTC) subscription activation, plan switch and deactivations have been delayed. These queued jobs will process when services are restored.
Posted Jan 25, 2023 - 14:13 EST
This incident affected: Iridium Activation and Subscription Billing.