Subscription Activation Services Delay
Incident Report for Garmin inReach
Resolved
This incident was resolved and services restored at 11:24am Eastern US time.
Posted Jan 21, 2022 - 11:24 EST
Investigating
New subscription service activations, plan changes and deactivations are not processing. This issue began at approximately 9:00 AM Eastern US time (2:00 PM UTC).
Posted Jan 21, 2022 - 09:39 EST
This incident affected: Iridium Activation and Subscription Billing and LTE Activation and Subscription Billing.