inReach Service Activation and Plan Changes Are Delayed
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Jun 23, 2022 - 15:02 EDT
Update
We are continuing to investigate this issue.
Posted Jun 23, 2022 - 14:48 EDT
Investigating
inReach service activation and plan changes are delayed. We recommend waiting until the issue is resolved before making any inReach service changes.
Posted Jun 23, 2022 - 13:52 EDT
This incident affected: Iridium Activation and Subscription Billing.