inReach account activation and plan change outage
Incident Report for Garmin inReach
Resolved
The issue has been resolved. inReach activations and service plan changes are working.
Posted Oct 17, 2017 - 19:15 EDT
Investigating
New inReach account activation and service plan changes are currently unavailable. We are investigating but have no estimate yet on the restoration of service. Updates will be provided when available.
Posted Oct 17, 2017 - 16:27 EDT
This incident affected: Iridium Activation and Subscription Billing.