Changes to subscription plans may not complete
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Apr 30, 2021 - 16:11 EDT
Update
We are continuing to investigate this issue.
Posted Apr 30, 2021 - 15:17 EDT
Investigating
Customers are unable to modify inReach subscription plans.  Subscription changes will get stuck processing after users try to complete the change from the Explore website.   We recommend waiting until after this issue is resolved to make subscription plan changes.
Posted Apr 30, 2021 - 13:30 EDT
This incident affected: Iridium Activation and Subscription Billing.