inReach Activation and Service Plan Change - Degraded Performance
Incident Report for Garmin inReach
Resolved
Upon investigation, while our system showed some errors, there was no actual effect on activation or service plan changes.
Posted Oct 05, 2017 - 12:04 EDT
Investigating
We're investigating issues with activating new inReach service and existing service plan changes.
Posted Oct 05, 2017 - 10:04 EDT
This incident affected: Iridium Activation and Subscription Billing and Garmin Explore Website and MapShare.