Messages to inReach devices delayed
Incident Report for Garmin inReach
Resolved
Delayed messages have been sent. All messaging is working.
Posted Apr 10, 2018 - 14:20 EDT
Identified
Starting at 1:36 PM Eastern US time, messages to inReach devices have been delayed. Updates will be provided.
Posted Apr 10, 2018 - 14:07 EDT
This incident affected: SMS/Text Communication, Email Communication, and SOS Communication.