inReach Service Activation and Plan Changes Maintenance
Incident Report for Garmin inReach
Resolved
Maintenance complete.
Posted Apr 10, 2018 - 14:50 EDT
Monitoring
From 11:00 AM - 3 PM Eastern US time, inReach service activation and plan changes may be delayed during the maintenance window.
Posted Apr 10, 2018 - 11:17 EDT
This incident affected: Iridium Activation and Subscription Billing.