inReach Login and Sync
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted 7 months ago. Jul 29, 2018 - 07:34 EDT
Update
We are continuing to work on a fix for this issue.
Posted 7 months ago. Jul 29, 2018 - 07:33 EDT
Identified
inReach users currently cannot login to the Explore Web Site and Sync Application. New Account creation is also offline. Users already logged in, may not be affected. Engineers are currently working to resolve.
Posted 7 months ago. Jul 29, 2018 - 06:41 EDT
This incident affected: Garmin Explore Website and MapShare and inReach Service Activation and Billing.