Explore website and inReach service activation outage
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Jun 23, 2019 - 04:01 EDT
Investigating
Since approximately 12AM Eastern US time on June 23rd, inReach service activation is inaccessible and Explore website is inaccessible to some users.
Posted Jun 23, 2019 - 01:05 EDT
This incident affected: Iridium Activation and Subscription Billing, Garmin Explore Website and MapShare, and Developer APIs.