Explore website and related features may be inaccessible
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 03:48 EDT
Investigating
Due to an apparent large scale internet issue, the Explore site is currently inaccessible to users in some regions. We are investigating the additional impacts of this.
Posted Jun 21, 2022 - 03:15 EDT
This incident affected: Garmin Explore Website and MapShare.