inReach/Iridium service activation and plan changes are delayed
Incident Report for Garmin inReach
Resolved
All delayed service activation and plan changes have completed.
Posted Jul 13, 2021 - 17:46 EDT
Investigating
New inReach/Iridium service activation and plan changes are currently delayed. This issue began at approximately 3:30 PM Eastern US time (19:30 GMT).
Posted Jul 13, 2021 - 16:32 EDT
This incident affected: Iridium Activation and Subscription Billing.