InReach Service Activation and Plan Change Outage
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 08, 2019 - 22:17 EST
Investigating
inReach service activation and plan changes are currently unavailable. We're investigating and will provide updates.
Posted 7 months ago. Mar 08, 2019 - 20:13 EST
This incident affected: inReach Service Activation and Billing.