Garmin Sign In Unavailable
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Sep 04, 2020 - 12:43 EDT
Investigating
Starting around 9:30 AM Eastern US time, Garmin Sign In has become increasingly unavailable for the Explore web site, inReach sync app, Explore mobile app, and Earthmate mobile app. This also affects syncing data between the web site and mobile apps.
Posted Sep 04, 2020 - 12:28 EDT
This incident affected: Garmin Sign In.