inReach Service Change Outage
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Aug 12, 2022 - 17:03 EDT
Investigating
Users are unable to activate or deactivate inReach services since 3:20PM EST (7:20PM UTC). We are investigating this now.
Posted Aug 12, 2022 - 16:09 EDT
This incident affected: Iridium Activation and Subscription Billing.