Delayed inReach service activation
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Jun 12, 2019 - 10:56 EDT
Investigating
Since approximately 6 PM Eastern US time (22:00 UTC) on June 11th, inReach service activation has been delayed. Updates will be provided.
Posted Jun 12, 2019 - 08:49 EDT
This incident affected: Iridium Activation and Subscription Billing.