Garmin Sign In Outage
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Sep 16, 2019 - 14:02 EDT
Investigating
Customers are currently unable to sign in to Garmin accounts, including the Explore web site and Explore app sync.
Posted Sep 16, 2019 - 11:57 EDT
This incident affected: Garmin Explore Website and MapShare.