Subscription Services Delay
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Nov 16, 2021 - 05:40 EST
Investigating
New subscription service activations, plan changes and deactivations are processing very slowly. This affects Iridium devices as well as LTE devices. These delays started at approximately 12:35 AM EST (5:35 AM GMT)
Posted Nov 16, 2021 - 04:00 EST
This incident affected: Iridium Activation and Subscription Billing and LTE Activation and Subscription Billing.