inReach and Explore Maintenance - Continuing Issues
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Nov 28, 2019 - 04:27 EST
Update
Remaining issue: inReach weather forecasts are not working.
Posted Nov 28, 2019 - 04:23 EST
Identified
We are working to resolve the remaining issues.
Posted Nov 28, 2019 - 04:19 EST
Investigating
Following the recent maintenance, we are investigating several lingering issues. inReach weather forecasts are not working. Logging into the Earthmate mobile app and inReach Sync desktop app is not working. Updates will be provided.
Posted Nov 28, 2019 - 02:39 EST
This incident affected: Garmin Explore Website and MapShare.