inReach Management Website Unavailable in Europe
Incident Report for Garmin inReach
Resolved
The issue has been resolved. The inReach web site is functional in Europe.
Posted Mar 11, 2018 - 07:31 EDT
Investigating
The inReach Management Website (inreach.garmin.com) is unavailable for European customers, starting about 2 hours ago.
Posted Mar 11, 2018 - 06:16 EDT
This incident affected: Garmin Explore Website and MapShare.