Activation and plan changes for Iridium, LTE, and Subscription Billing Outage
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Aug 09, 2022 - 00:29 EDT
Update
We are continuing to investigate this issue.
Posted Aug 09, 2022 - 00:04 EDT
Investigating
We are currently investigating the issue.
Posted Aug 08, 2022 - 23:37 EDT
This incident affected: Iridium Activation and Subscription Billing and LTE Activation and Subscription Billing.