Most customers unable to sign in to the Explore web site
Incident Report for Garmin inReach
Resolved
All customers should now be able to sign in.
Posted 6 months ago. Jan 03, 2019 - 15:08 EST
Investigating
Most customers are currently unable to sign in to the Explore web site. Customers who are already signed in should be able to use the site normally. Updates will be provided.
Posted 6 months ago. Jan 03, 2019 - 14:21 EST
This incident affected: Garmin Explore Website and MapShare.