Explore site sign in and inReach Sync app sign in outage
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted 11 months ago. Aug 24, 2018 - 19:18 EDT
Investigating
Signing in to the Explore site and the inReach Sync app is intermittently unavailable. Updates will be provided. inReach communication is not affected.
Posted 11 months ago. Aug 24, 2018 - 16:54 EDT
This incident affected: Garmin Explore Website and MapShare.