Explore site sign in and inReach Sync app sign in outage
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted 9 months ago. Jul 30, 2018 - 18:54 EDT
Investigating
Signing in to the Explore site and the inReach Sync app is intermittently unavailable. Updates will be provided. inReach communication is not affected.
Posted 9 months ago. Jul 30, 2018 - 17:47 EDT
This incident affected: Garmin Explore Website and MapShare.