Delayed inReach service activation / deactivation
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Aug 15, 2019 - 11:53 EDT
Investigating
We are currently investigating delayed inReach activations and deactivations.
Posted Aug 15, 2019 - 10:34 EDT
This incident affected: Iridium Activation and Subscription Billing.