Explore web site slowness
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Nov 28, 2019 - 11:40 EST
Investigating
Some customers may be experiencing slowly loading pages or pages that fail to load on the Explore web site.
Posted Nov 28, 2019 - 10:57 EST
This incident affected: Garmin Explore Website and MapShare.