inReach messages and track points not appearing on the Explore site and MapShare
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted 3 months ago. Nov 19, 2018 - 05:01 EST
Investigating
We are investigating. Updates will be provided.
Posted 3 months ago. Nov 19, 2018 - 00:02 EST
This incident affected: Garmin Explore Website and MapShare.