SMS messaging delay
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted 8 months ago. Aug 28, 2018 - 12:23 EDT
Investigating
SMS messaging is currently experiencing some delays. Updates will be provided.
Posted 8 months ago. Aug 28, 2018 - 12:04 EDT
This incident affected: SMS/Text Communication.