Outage for inReach Service Activations and Some Plan Changes
Incident Report for Garmin inReach
Resolved
inReach service activation and plan changes are now working properly.
Posted Jul 14, 2017 - 10:44 EDT
Investigating
Anticipated Time of Resolution: Unknown

Impact: New inReach service activation and some existing service plan changes are currently not working.
Posted Jul 14, 2017 - 10:06 EDT