New inReach service activation and plan change delay
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted 6 months ago. Oct 16, 2018 - 13:07 EDT
Investigating
New inReach service activation and plan changes are currently delayed. Pending changes will happen once the incident is resolved. Updates will be provided.
Posted 6 months ago. Oct 16, 2018 - 10:03 EDT
This incident affected: inReach Service Activation and Billing.