Delayed: Creating a Garmin Explore account
Incident Report for Garmin inReach
Resolved
inReach activations are no longer delayed. New Explore accounts are no longer delayed.
Posted Oct 22, 2020 - 06:05 EDT
Monitoring
inReach activations are no longer delayed. New Explore accounts are being created but are delayed.
Posted Oct 21, 2020 - 23:56 EDT
Update
inReach activations are currently delayed.
Posted Oct 21, 2020 - 16:33 EDT
Investigating
Customers attempting to create a new Garmin Explore account via the Garmin Explore mobile app are experiencing an outage.
Posted Oct 21, 2020 - 14:21 EDT
This incident affected: Iridium Activation and Subscription Billing and Garmin Explore Mobile App.