Creating new users and contacts unavailable for some customers
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted 4 months ago. Jan 04, 2019 - 13:09 EST
Investigating
Some customers may experience issues when trying to make new users on their account or when trying to add contacts.
Posted 4 months ago. Jan 03, 2019 - 11:44 EST
This incident affected: Garmin Explore Website and MapShare.