Delays with inReach subscription activations, deactivations and plan changes

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 11:51 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 23, 2025 - 10:16 EDT

Investigating

Customers may experience delays with inReach activations, deactivations, and plan changes.
Posted Jun 23, 2025 - 09:32 EDT
This incident affected: Iridium Activation and Subscription Billing.