Outage: New inReach service activation and existing service plan changes
Incident Report for Garmin inReach
Resolved
The issue has been resolved. New inReach service activation and plan changes are working normally.
Posted about 1 year ago. Jul 09, 2018 - 18:29 EDT
Investigating
There is currently an outage for customers trying to activate new inReach service or make plan changes to existing service. This issue began around 3 PM Eastern time. Updates will be provided.
Posted about 1 year ago. Jul 09, 2018 - 16:11 EDT
This incident affected: inReach Service Activation and Billing.