Explore websites unavailable
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted 6 months ago. Nov 05, 2018 - 23:28 EST
Update
We are continuing to investigate this issue.
Posted 6 months ago. Nov 05, 2018 - 22:45 EST
Investigating
Explore.garmin.com and MapShare (share.garmin.com) are currently unavailable. We are investigating and will provide updates. inReach communication is unaffected.
Posted 6 months ago. Nov 05, 2018 - 22:21 EST
This incident affected: Garmin Explore Website and MapShare.