inReach service activation and plan change outage
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Sep 26, 2019 - 11:33 EDT
Investigating
New inReach service activation and existing plan changes are currently experiencing an outage. Updates will be provided.
Posted Sep 26, 2019 - 10:14 EDT
This incident affected: Iridium Activation and Subscription Billing.