Iridium service changes are failing

Incident Report for Garmin Services

Resolved

This incident has been resolved.
Posted Jan 04, 2022 - 22:25 EST

Investigating

New Iridium subscription service activations, plan changes and deactivations are failing. These delays started at approximately 5:05PM EST (22:05 GMT).

Tasks delayed by this outage should retry and complete automatically when service is returned.
Posted Jan 04, 2022 - 17:47 EST
This incident affected: Iridium Activation and Subscription Billing.