Explore Website, Degraded Performance
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Aug 30, 2023 - 13:11 EDT
Identified
Some customers may experience issues with several functions of the Explore website, including managing data, deleting data, and viewing messages. These issues do not impact device messaging or SOS functionality.
Posted Aug 30, 2023 - 06:48 EDT
This incident affected: Garmin Explore Website and MapShare.