inReach Service Activation and Plan Change Outage
Incident Report for Garmin inReach
Resolved
This incident has been resolved.
Posted Jun 25, 2019 - 22:58 EDT
Investigating
inReach service activation and plan changes are currently unavilable. Updates will be provided.
Posted Jun 25, 2019 - 21:46 EDT
This incident affected: Iridium Activation and Subscription Billing.